通达信鳄鱼涨停板金钻公式,源码分享(图文)

时间:2019-12-16 14:34:41 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

{鳄鱼涨停板11_源码---金钻公式}

VAR0 := ((C - MA(C,60)) / MA(C,60)) * 100;

VAR1 := (COUNT(MA(C,13) > MA(C,210),100)) >= 95;

VAR2 := (COUNT(VAR0 < 35,100)) >= 80;

VAR3 := (COUNT(C > MA(C,210),100)) >= 95;

VAR4 := (COUNT((((MA(C,13) - MA(C,210)) / MA(C,210)) * 100) < 35,100)) >= 90;

VAR5 := (((REF(C,1) - MA(C,210)) / MA(C,210)) * 100) < 35;

VAR6 := ((((VAR1 AND VAR2) AND VAR3) AND (MA(C,13) > MA(C,210))) AND (MA(C,210) > REF(MA(C,210),3))) OR (((VAR4 AND VAR5) AND (MA(C,13) > MA(C,210))) AND (MA(C,210) > REF(MA(C,210),3)));

VAR7 := MA(LOW,20) * 1.1;

VAR8 := (((REF(C,1) / REF(C,6)) < 1.15) OR (REF(C,1) < REF(C,3))) OR ((REF((HHV(HIGH,5) - LLV(LOW,5)) / LLV(LOW,5),1)) < 0.15);

VAR9 := (((C / REF(C,1)) > 1.05) AND (C > OPEN)) AND (FROMOPEN <= 240);

VAR10 := REF((((HHV(C,200) / LLV(C,200)) - 1) * 100) <= 40,1);

VAR11 := (C / LLV(LOW,80)) <= 1.45;

VAR12 := (((((CROSS(C,VAR7) AND VAR6) AND VAR9) AND (C > REF(HHV(HIGH,200),1))) AND VAR8) AND VAR10) AND VAR11;

VAR13 := VAR12 AND ((REF(BARSLAST(VAR12),1) >= 50) OR (BARSSINCE(VAR12) = 0));

VAR14 := ((C - MA(C,210)) / MA(C,210)) * 100;

VAR15 := (COUNT(MA(C,13) > MA(C,210),50)) >= 30;

VAR16 := (COUNT(VAR14 < 35,50)) >= 30;

VAR17 := (COUNT(C > MA(C,210),50)) >= 30;

VAR18 := (COUNT((((MA(C,13) - MA(C,60)) / MA(C,60)) * 100) < 30,60)) >= 20;

VAR19 := ((((REF(C,1) - MA(C,60)) / MA(C,60)) * 100) < 35) AND ((((C - MA(C,60)) / MA(C,60)) * 100) > 0);

VAR20 := (((((VAR15 AND VAR16) AND VAR17) AND (MA(C,13) > MA(C,210))) AND (MA(C,210) > MA(C,250))) OR (((VAR18 AND VAR19) AND (MA(C,13) > MA(C,210))) AND (MA(C,210) > MA(C,250)))) OR ((VAR18 AND VAR19) AND (MA(C,60) > MA(C,250)));

VAR21 := (((REF(C,1) / REF(LOW,6)) < 1.15) OR (REF(C,1) < REF(C,3))) OR ((REF((HHV(HIGH,5) - LLV(LOW,5)) / LLV(LOW,5),1)) < 0.15);

VAR22 := (((C / REF(C,1)) > 1.065) AND (C > OPEN)) AND (FROMOPEN <= 240);

VAR23 := REF((((HHV(C,15) / LLV(C,15)) - 1) * 100) <= 15,1);

VAR24 := (C / LLV(LOW,80)) <= 1.45;

VAR25 := (((((CROSS(C,VAR7) AND VAR20) AND VAR24) AND VAR22) AND (C > REF(HHV(HIGH,50),1))) AND VAR21) AND VAR23;

VAR26 := VAR25 AND ((REF(BARSLAST(VAR25),1) > 50) OR (BARSSINCE(VAR25) = 0));

鳄鱼嘴涨停板 : VAR13 OR VAR26;

STICKLINE(鳄鱼嘴涨停板,0,98,3,0),COLORRED;

DRAWTEXT(鳄鱼嘴涨停板,85,1),COLORYELLOW;

DRAWICON(鳄鱼嘴涨停板 > 0,65,5);

DRAWICON(鳄鱼嘴涨停板 > 0,50,1);

DRAWICON(鳄鱼嘴涨停板 > 0,35,7);

DRAWICON(鳄鱼嘴涨停板 > 0,25,9);

 


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)