通达信公式量化趋势线主图(图文)

时间:2019-07-22 15:20:28 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

QQ1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,QQ1*(HIGH-LOW),IF(CLOSE<OPEN,QQ1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖:=IF(CLOSE>OPEN,0-QQ1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-QQ1*(HIGH-LOW),0-VOL/2));
DD:=(主买+主卖)/10000;
DDX1:=EMA(DD,60)*60;
DDX2:=MA(DDX1,5);
DDX3:=MA(DDX1,13);
{分析家公式网www.88gs.com}
STICKLINE(DDX1<DDX3,H,L,0,0),COLORGREEN;
STICKLINE(DDX1<DDX3,C,O,2.8,0),COLOR00B500;
STICKLINE(DDX1<DDX3,C,O,2.6,0),COLOR00C600;
STICKLINE(DDX1<DDX3,C,O,2,0),COLOR00D500;
STICKLINE(DDX1<DDX3,C,O,1,0),COLOR00E600;
STICKLINE(DDX1>DDX3,H,L,0,0),COLOR106FFF;
STICKLINE(DDX1>DDX3,C,O,2.8,0),COLOR0000C8;
STICKLINE(DDX1>DDX3,C,O,2.6,0),COLOR0000D7;
STICKLINE(DDX1>DDX3,C,O,2,0),COLOR0000EA;
STICKLINE(DDX1>DDX3,C,O,1,0),COLOR0000FF;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,H,L,0,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2.8,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2.6,0),COLORFF7710;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2,0),COLORFF9910;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,H,L,0,0),COLORFF00FF;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2.8,0),COLORD000D0;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2.6,0),COLORE600E6;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2,0),COLORF900F9;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,1,0),COLORFF09FF;
{风险提示}
MA2:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
K:=SMA(VARF,3,1);
顶:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(K>79),H*1.02,"风险"),COLORYELLOW;
{量化趋势线}
降:=HHV(EMA(C,3),8),COLORCYAN;
升:=LLV(EMA(C,3),8),COLORRED;
走势:=EMA(C,3),COLORYELLOW;
线上多:IF(走势<降,降,DRAWNULL),COLORCYAN,LINETHICK2;
线下空:IF(走势>升,升,DRAWNULL),COLORMAGENTA,LINETHICK2;

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)