妖股主图(通达信公式 主图 源码 测试图)(图文)

时间:2019-12-22 23:04:08 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

X_1:=(EMA(CLOSE,12)/EMA(CLOSE,26)-1)*1000;
X_2:=(EMA(INDEXC,12)/EMA(INDEXC,26)-1)*1000;
X_3:=EMA(X_1,5);
X_4:=EMA(X_2,5);
X_5:=X_3-REF(X_3,1);
X_6:=X_4-REF(X_4,1);
X_7:=IF(X_5-X_6>0,(X_5-X_6)*5,0);
X_8:=X_7-REF(X_7,1);
X_9:=主力进场.低买.低买#DAY;
X_10:=牛逼.XG#DAY;
X_11:=EMA(X_10,12)-EMA(X_10,26);
X_12:=EMA(X_11,9);
X_13:=(X_11-X_12)*2;
X_14:=HHVBARS(X_13,BARSLAST(X_13<0)+1);
X_15:=CROSS(BACKSET(CROSS(0,X_13),REF(X_14,1)+2),0.5);
X_16:=DRAWLINE(X_15,X_13,REF(X_15,1),REF(X_13,1),1);
X_17:=X_13>X_16 AND X_13>=REF(X_13,1);
X_18:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW=HIGH;
X_19:=分析幅图.指数#DAY;
X_20:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND LOW<HIGH;
X_21:=HIGH>=ZTPRICE(REF(CLOSE,1),0.1) AND CLOSE<HIGH;
X_22:=1+3*X_20+1*X_18+0.2*X_21;
X_23:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_24:=X_23*X_22;
X_25:=安安.指数#DAY;
X_26:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_27:=IF(CLOSE>OPEN,X_25*(HIGH-LOW),IF(CLOSE<OPEN,X_25*(HIGH-OPEN+(CLOSE-LOW)),IF(CLOSE=OPEN AND CLOSE>REF(CLOSE,1),VOL*0.7,VOL*0.3)));
X_28:=IF(CLOSE>OPEN,X_25*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,X_25*(HIGH-LOW),IF(CLOSE=OPEN AND CLOSE<REF(CLOSE,1),VOL*0.7,VOL*0.3)));
X_29:=IF(CLOSE>OPEN,X_26*(HIGH-LOW),IF(CLOSE<OPEN,X_26*(HIGH-OPEN+(CLOSE-LOW)),VOL/2));
X_30:=SUM((X_27-X_28)/CAPITAL,1)*1000;
X_31:=红柱1.红柱#DAY;
X_32:=IF(X_31>30,1,IF(X_31>3 AND X_31<=30,33,IF(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1) AND X_31<=2,X_31*20,X_31)));
X_33:=IF(CLOSE>=REF(CLOSE,1) AND X_31>3,33,IF(CLOSE<REF(CLOSE,1) AND X_31>3,0,IF(CLOSE>=REF(CLOSE,1) AND X_31<=3,X_31*10,X_31)));
X_34:=1;
X_35:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4*X_34;
X_36:=周金叉#DAY;
X_37:=EMA(X_36,30)*X_34;
X_38:=2*(X_36-X_37)*10*X_34;
X_39:=POW(X_38,3)*0.1+POW(X_38,2)*X_34;
X_40:=IF(X_38>0.015,X_39,0)/45*X_34;
X_41:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
X_42:=X_13-REF(X_13,1);
X_43:=DYNAINFO(4)>0;
X_44:=EXIST(ABS(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.052,20) AND EXIST(CLOSE/REF(CLOSE,1)>1.15,2)!=1;
X_45:=FINANCE(40)<300*100000000 AND FINANCE(7)<=流通盘小于亿*100000000;
X_46:=X_44 AND X_43 AND X_19!=1 AND AMOUNT/10000>1000;
X_47:=金钻MACD幅图1#DAY;
X_48:=X_9;
X_49:=INDEXADV/(INDEXADV+INDEXDEC)*100;
X_50:=X_49>85 OR REF(X_49,1)>85;
X_51:=INDEXC-MA(INDEXC,7);
X_52:=(HHV(X_51,60)-0)*60/100;
X_53:=X_51>X_52;
X_54:=X_50=1 OR X_53=1;
X_55:=IF(震荡过滤=1,X_54,0);
X_56:=CLOSE>=OPEN;
X_57:=(CLOSE-X_41)/X_41*100*2;
优选:IF(FROMOPEN>10 AND X_55!=1 AND X_46 AND X_45 AND X_47 AND X_56 AND X_10 AND 17=1,(X_30+X_8*3+X_24+X_32+X_42*5+X_57)*3,0),NODRAW,COLORMAGENTA;
妖股启动:X_57*0.8,NODRAW,COLORMAGENTA;
X_58:=妖股启动>0;
X_59:=优选>0;
X_60:=优选+妖股启动>=300;
X_61:=X_58 AND X_59;
X_62:=FILTER(X_61,5);
DRAWTEXT(X_62,LOW*0.92,94),COLORMAGENTA;
STICKLINE(X_62,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(X_62,OPEN,CLOSE,1,0),COLORMAGENTA;
DRAWICON(FILTER(X_62>0,1),LOW*0.98,24);
DRAWICON(FILTER(X_62>0,1),LOW*0.95,25);
DRAWICON(FILTER(X_62>0,1),LOW*0.92,26);
变:EMA(CLOSE,5),COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN;
X_63:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(OPEN,1),1,0);
STICKLINE(X_63,OPEN,CLOSE,1,0),COLORYELLOW;
X_64:=7;
X_65:=7;
X_66:=10;
X_67:=120;
X_68:=1;
X_69:=大盘 A#DAY;
X_70:=大盘 A.出击#DAY;
X_71:=X_69;
X_72:=(X_69+X_70)/2;
X_73:=X_70;
上线:IF(1,REF(X_71,1),DRAWNULL),NODRAW,COLOR0000CC;
中线:IF(1,REF(X_72,1),DRAWNULL),NODRAW,COLORWHITE;
下线:IF(1,REF(X_73,1),DRAWNULL),NODRAW,COLORCCCC00;
X_74:=CURRBARSCOUNT<2;
X_75:=CURRBARSCOUNT<13;
X_76:=IF(X_74,上线,DRAWNULL);
X_77:=IF(X_74,中线,DRAWNULL);
X_78:=IF(X_74,下线,DRAWNULL);
X_79:=IF(X_75,X_76,DRAWNULL);
X_80:=IF(X_75,X_77,DRAWNULL);
X_81:=IF(X_75,X_78,DRAWNULL);
STICKLINE(X_75,X_79,X_79,20,(-1)),COLOR0000CC;
STICKLINE(X_75,X_80,X_80,20,(-1)),COLORWHITE;
STICKLINE(X_75,X_81,X_81,20,(-1)),COLORCCCC00;
X_82:=PK金钻#DAY;
X_83:=Func_0x75F0.SubValue_0x1#DAY;
X_84:=Func_0x75F0.SubValue_0x2#DAY;
X_85:=BARSLASTCOUNT(CLOSE<X_84);
X_86:=BACKSET((X_85>=4)*X_85,X_85);
X_87:=BARSLASTCOUNT(CLOSE>X_84);
X_88:=BACKSET((X_87>=4)*X_87,X_87);
X_89:=BARSLASTCOUNT(NOT(X_86 OR X_88));
X_90:=BARSLASTCOUNT(REF(X_86>0,X_89));
X_91:=BARSLASTCOUNT(REF(X_88>0,X_89));
X_92:=IF(X_7=1,0,FILTERX(LLV(X_83,X_90)=X_83,X_90));
X_93:=IF(X_8=1,0,FILTERX(HHV(X_82,X_91)=X_82,X_91));
X_94:=IF(X_7=1,0,REF(X_82,BARSLAST(X_93)));
X_95:=IF(X_8=1,0,REF(X_83,BARSLAST(X_92)));
X_96:=IF(DATE<1990705,BARSLAST(X_90=1),0);
X_97:=REF(X_94,BARSLAST(X_90));
X_98:=REF(X_95,X_96);
X_99:=(X_97-X_98)*0.191+X_98;
X_100:=(X_97-X_98)*0.382+X_98;
X_101:=(X_97-X_98)*0.5+X_98;
X_102:=(X_97-X_98)*0.618+X_98;
X_103:=(X_97-X_98)*0.809+X_98;
X_104:=X_97+(X_97-X_98)*0.191;
X_105:=X_98-(X_97-X_98)*0.191;
X_106:=REFDATE(X_98,DATE);
X_107:=REFDATE(X_100,DATE);
X_108:=REFDATE(X_102,DATE);
X_109:=REFDATE(X_97,DATE);
X_110:=REFDATE(X_104,DATE);
X_111:=REFDATE(X_105,DATE);
DRAWBAND(X_106,RGB(68,68,0),X_111,RGB(68,68,0));
DRAWBAND(X_110,RGB(78,78,0),X_109,RGB(78,78,0));
X_112:=Func_0x75FD.SubValue_0x3#DAY=1;
X_113:=Func_0x75FD.SubValue_0x4#DAY=1;
X_114:=蝴蝶精确底#DAY;
X_115:=蝴蝶精确底.MA05#DAY;
X_116:=蝴蝶精确底#DAY;
X_117:=1.06*X_116;
X_118:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6;
X_119:=EMA(HIGH,10)*(1+6/100);
X_120:=X_112=0 AND X_118>0 AND CROSS(CLOSE,X_119) AND CROSS(CLOSE,X_117);
X_121:=FILTER(CROSS(X_114,EMA(HIGH,55)*(1+10/100)),5);
X_122:=IF(X_112=0 AND X_120,1,0);
X_123:=IF(X_112=0 AND X_121,1,0);
DRAWICON(X_122,LOW*0.97,34);
DRAWICON(X_123,HIGH*1.03,27);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK),COLOR00CCCC;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK),COLOR00CCCC;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,GNBLOCK),COLOR00CCCC;
 

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)